[ZOOM] Re: zoom.hh

Mike Taylor mike at tecc.co.uk
Thu Nov 29 13:24:57 CET 2001

> Date: Thu, 29 Nov 2001 12:03:23 +0000
> From: Ashley Sanders <zzaascs at irwell.mimas.ac.uk>
> > > Which I think isn't too cumbersome to write.
> > 
> > Wow.
> Honestly, it isn't.


> If the variable and class names weren't so long it would look a lot
> nicer.

I thought we'd done a fine job in keeping the names nice and short.

> We can also define operator[] as an alias of getRecord().

Oh, please let's not even discuss that again!  :-)

> Are the following any better?
> [examples snipped]

Well, not necessarily _better_ but you have effectively illustrated
that we are doing the right thing in offering the bits and pieces that
programmers can use to build their applications using whichever style
suits them best.

> > > But really, I can't see a reason why you would want your own
> > > copy of a record. The resultSet object is already a handy
> > > container for keeping them in.
> > 
> > Again, the reason you might want this is if the resultSet object
> > is transient, so the record is supposed to live longer than it.
> My answer to that of course is make sure your resultSet objects last
> until you no longer need what they contain.

I don't think it's our job, as API specifiers, to force people to
write their applications in a particular way.  If people want to write
a function that returns just a record without requiring the caller to
know _anything_ about resultSets, then we should allow them to do so.

> (several of our libraries cannot supply unquie record control
> numbers for instance.)

Then they could not be used as Zthes databases.  Separate issue.

 _/|_	 _______________________________________________________________
/o ) \/  Mike Taylor   <mike at miketaylor.org.uk>   www.miketaylor.org.uk
)_v__/\  "I don't have any solution but I certainly admire the problem"
	 -- Ashleigh Brilliant.

More information about the ZOOM mailing list