[Zebralist] installing zebra package on debian etch on an amd64 system

Walter McGinnis walter at katipo.co.nz
Wed Jan 10 01:03:01 CET 2007


On Jan 9, 2007, at 9:09 PM, Adam Dickmeiss wrote:

> Walter McGinnis wrote:
>> Hello again,
>> I'm having some problems installing from the Debian packages of  
>> Zebra after making the switch to a system that runs on amd64  
>> rather than i386.  I could use some advice on how to make it work.
>
> We only provide binaries for i386 at this time. For other  
> architectures, refer to
>
> http://indexdata.dk/zebra/doc/installation-debian.tkl#installation- 
> debia-nother
>
> You probably need to install YAZ first. Let us know about your  
> progress (so we can improve the documentation).
>
> / Adam
>

I did the following after editing my /etc/apt/sources.list to only  
hit the src packages as root:

$ apt-get update

$ apt-get upgrade # just for the sake of it

$ apt-get build-dep libyaz-dev

$ apt-get source --compile libyaz-de

$ dpkg -i libyaz-dev_2.1.44-1_amd64.deb libyaz_2.1.44-1_amd64.deb

$ apt-get build-dep idzebra-2.0

$ apt-get source --compile idzebra-2.0

$ dpkg -i idzebra-2.0*.deb libidzebra-2.0*.deb # note no "install"  
after the -i, that is redundant

I haven't started up zebra or yaz yet, but things seem to be in the  
right places.

Thanks for the help!

Cheers,
Walter






More information about the Zebralist mailing list