[Zebralist] Correct Syntax for connecting to multiple "logical"databases

Joe Bacom joe at docsimple.com
Mon Dec 10 15:36:58 CET 2007


Hi Merijn;

Thanks for the reply.  Yes it is possible to connect to two or more databases 
simultaneously with yaz-client and thanks to Heikki, I now know the correct 
syntax. I'm still testing to see if searching is any faster from splitting my 
full-text and properties into separate databases.  If you're interested, I 
can post my results.

Thanks again,

Joe

On Friday 07 December 2007 07:58, Merijn van den Kroonenberg wrote:
> On Thursday 29 November 2007 17:11, Joe Bacom wrote:
> > Hi Folks;
> >
> > I've defined multiple databases in my zebra.cfg, created them, added some
> > files to them with zebraidx and now I'm trying to connect to both with
> > yaz-client.  Here's the syntax I'm using:
>
> I am new to zebra too. Are you sure its possible to connect to multiple
> databases at the same time? I have not read anything about this. You can
> switch your current database on a active connection with the "base"
> command. So you can do one query on one database and the following query on
> another database.
>
> > yaz-client -u username/password localhost:52300/db1+db2
>
> I think the yaz client tries to connect to the database "db1+db2". This
> database does not exist (and you have no access rights to it), so thats
> probably why you get the error below.
>
> Are you sure you need to split your data over multiple databases? I am not
> sure if it would be a big improvement. I would say, do a test with a simple
> setup first. Then do some benchmarking to see if its actually usefull to
> split over multiple databases. (this in response to your second mail)
>
> > and I get the resulting message:
> > Authentication set to Open (username/password)
> > Connecting...OK.
> > Sent initrequest.
> > Connection accepted by v3 target.
> > ID     : 81
> > Name   : Zebra Information Server/GFS/YAZ
> > Version: Zebra 2.0.6/1.108/2.1.44
> > Options: search present delSet triggerResourceCtrl scan sort
> > extendedServices namedResultSets
> > Elapsed: 0.002881
> >
> > All looks fine (I think) but when I run a query
> > f @and @attr 1=type user @attr 1=name joe
> > Sent searchRequest.
> > Received SearchResponse.
> > Search was a bloomin' failure.
> > Number of hits: 0, setno 1
> > records returned: 0
> > Diagnostic message(s) from database:
> >     [236] Access to specified database denied -- v2 addinfo ''
> > Elapsed: 0.000546
> >
> > I've checked the username and password and their correct so it seems I
> > must
> > have the connection syntax incorrect.
> >
> > Thanks;
> >
> > Joe
>
> Merijn van den Kroonenberg,
>
> Web2All B.V.
> Telefoon: +31 475 775511
> Fax:        +31 475 338290
> Email:      merijn at web2all.nl
> Website:  http://www.web2all.nl
>
>
> _______________________________________________
> Zebralist mailing list
> Zebralist at lists.indexdata.dk
> http://lists.indexdata.dk/cgi-bin/mailman/listinfo/zebralist

-- 
Stop paying your lunch money to a bully.
		OpenOffice.org

Penguin: Linux version 2.6.18 x86_64, 22,406.73 BogoMips
Skype: joebacom
AOL: joeb1002
Yahoo: joebacom
Jabber: bacomj
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://lists.indexdata.dk/pipermail/zebralist/attachments/20071210/1d22f470/attachment.pgp 


More information about the Zebralist mailing list