[Zebralist] Problem getting zebra 1.1 working on RH Linux 7.2

Simon McLeish s.mcleish at lse.ac.uk
Thu Jan 10 13:26:16 CET 2002


Hi again,

I've now sorted the "[114] Unsupported Use attribute --  v2 addinfo '1016 
error, by removing yaz 1.8.3 which was installed with the RPM and installing 
yaz 1.8.4 by compiling the source code. I could then recompile zebra without 
having to change any of the make files, but I still get the some of the 
problems that I had before.

zebraidx thinks that all records are new insertions even if they're identical 
to ones already indexed (even when I only set up one database) and I get 
"[109] Database unavailable -- v2 addinfo 'test'" errors when I try to search 
the first indexed of two databases. (I indexed the test/gils database twice, 
once with "-d test" and then with "-d test2".) More help would be welcome.

Thanks,
Simon

On Tuesday 08 Jan 2002 12:32 pm, Neil Prockter wrote:
> Hello Simon
> I have it running on rh7.2. I think the key is not to alter the makefile
> but instead to have the readline41 and readline2.2.1 packages installed.
> It should compile fine.
> As for 2 dababases what is your zebra.conf? / how did you index?
> Neil
>
> Original Message dated 08/01/02, 12:07:29
> Author: "Mcleish,S" <S.Mcleish at lse.ac.uk>
> Re: [Zebralist] Problem getting zebra 1.1 working on RH Linux 7.2:
>
>
> Hi,
> Has anyone got zebra 1.1 working on a RH Linux 7.2 machine (using gcc v.
> 3.02/ glibc 2.2.4 and yaz 1.8.3)? I got it to compile after editing some
> of
> the makefiles manually so that the history library was included every
> time
> the readline library is included (i.e. I replaced "-lreadline" with
> "-lreadline -lhistory").
> Then I get the following behaviour:
> * each time zebraidx is run, it thinks that it's adding all the records
> as new
> * if only one database is set up, searching it returns sensible results
> but
> when a second database is indexed - I used the usmarc and gils one
> together -
> the first database gives "[109] Database unavailable -- v2 addinfo
> 'Default'"
> and the second gives "[114] Unsupported Use attribute -- v2 addinfo
> '1016'"
> for the simple "find surficial" search
> * The same happens with databases which worked fine with zebra v 1.0b1 on
> an
> alpha machine. (Replacing this machine, now out of warranty, is the
> motivation for doing this.)
> Has anyone got any suggestions?
> Thanks,
> Simon
> _______________________________________________
> Zebralist mailing list
> Zebralist at indexdata.dk
> http://www.indexdata.dk/mailman/listinfo/zebralist



More information about the Zebralist mailing list