[Yazlist] Simple question to start the server Z39

Boucher Stéphane boucherstephane at mideel.fr
Mon Nov 23 11:26:15 UTC 2020


Hello Adam,
thank you for your response.

Indeed, PMB Services has diverted the use of yaz-ztest. I understood it 
by rereading the PMB documentation and by repeating each step.
PMB Services gives a ztest.c file that must be compiled with your 
sources by replacing your original ztest.c file.
With version 2.0.9 of YAZ, the compilation works without error.

Once the yaz-ztest server is launched, I get this error when a client 
connects to it :

Launching the server for testing :

sudo /usr/local/bin/yaz-ztest -c /var/www/pmb_lourdes/zserver/zserver.ini tcp:localhost:210

Starting server /usr/local/bin/yaz-ztest pid=11517
Adding dynamic Z3950 listener on tcp:localhost:210
Entering event loop.


In another console, I connect as a client :

sudo /usr/local/bin/yaz-client  tcp:localhost:210/lourdes
Connecting...OK.
Sent initrequest.
Connection rejected by v3 target.
ID     : 81
Name   : GFS/YAZ
Version: 1.13/2.0.9
Init response contains 1 otherInfo unit:
   1: otherInfo unit contains 1 diagnostic:
     1: code=2 (Temporary system error),
     addinfo=''
Options: search present delSet scan sort extendedServices namedResultSets
Elapsed: 0.002815
Z>

And I have these messages in the server console (if I connect with PMB, 
I have the same message, only the version of YAZ changes)

Starting session 1 from tcp:localhost
Got initRequest
Id:        81
Name:      YAZ
Version:   2.0.9
param webpmb_host localhost
param webpmb_port 80
param webpmb_script /pmb_lourdes/admin/convert/export_z3950.php
param z3950_database lourdes
Can't handle configuration file
Negotiated to v3: srch prst del extendedServices namedresults scan sort
Connection rejected by backend.
[2] Temporary system error
Final timeout - closing connection.


I don't think the problem is caused by Yaz's version.

It finds the config file, but I have a feeling It doesn't.
I tried changing the webpmb_script path or using export_z3959_new.php 
but it doesn't change anything.
I think that yaz-ztest ignores the configuration file because if I don't 
specify a file or if I specify an empty file, I get the same error message.

Thank you for any help you could give me.

Stéphane

Le 23/11/2020 à 10:53, Adam Dickmeiss a écrit :
>
>
> On Thu, Nov 19, 2020 at 11:46 AM Boucher Stéphane 
> <boucherstephane at mideel.fr <mailto:boucherstephane at mideel.fr>> wrote:
>
>     Hello,
>     I am not a programmer but an administrator.
>     I'm trying to configure the Z39.50 server of the PMB software. It is
>     based on the YAZ library.
>
>     The only documentation concerning the Z39 server of PMB is this one:
>     https://www.amelycor.fr/pmb/zserver/guide.pdf (French software so
>     in French)
>
>     It mentions only the yaz-ztest command to start the server.
>
>     But by reading your documentation
>     (https://software.indexdata.com/yaz/doc/yaz-ztest.html), I understand
>     that yaz-ztest only allows testing. I deduce that whatever the
>     database
>     it indicates (example db.myDB), yaz-ztest will ignore it and will
>     send
>     me only results from its test set.
>     Is this correct ?
>
>
> The yaz-ztest software that is part of YAZ is a server for testing. It 
> does not connect to a storage module or other backend.
>
> But reading from the documentation you have, it seems that yaz-ztest 
> is something different.
>
> It is a little weird to use the same name for a different piece of 
> software.. Perhaps the Windows makefile that is part of YAZ was just 
> used as is and the implementation was updated to contact some PMB 
> server behind it.
>
>
>     In this case, what is the command to use to start the real Z39 server
>     and not the test server ?
>
> I think the command to start your server is probably correct. But we 
> don't know as we don't provide the PMB software in any way.
>
> / Adam
>
>
>     My question may sound stupid to you. But, I can't find any
>     resources on
>     the French net and very few on the US net. As for the developers
>     of the
>     PMB software, they don't answer for the moment.
>
>     For information, here are the commands I use for my tests.
>
>     The Z39 server :
>     usr/local/bin/yaz-ztest -c ./zserver.ini tcp:localhost:210
>
>     with this configuration file zserver.ini :
>     #Configuration file for the z3950 server
>     #Parameters for the http PMB gateway
>     webpmb_host=localhost
>     webpmb_port=80
>     webpmb_script=/pmb_lourdes/admin/convert/export_z3950_new.php
>     #Z3950 server settings
>     z3950_database=db.lourdes
>
>     The client: sudo /usr/local/bin/yaz-client
>     tcp:localhost:210/db.lourdes
>
>
>     And if I go through PMB's interface, the client works too.
>
>     My OS is Debian10.
>
>     Thanks for your help.
>     Best regards
>
>
>     Stéphane Boucher
>
>
>     _______________________________________________
>     Yazlist mailing list
>     Yazlist at lists.indexdata.dk <mailto:Yazlist at lists.indexdata.dk>
>     http://lists.indexdata.dk/cgi-bin/mailman/listinfo/yazlist
>
>
> _______________________________________________
> Yazlist mailing list
> Yazlist at lists.indexdata.dk
> http://lists.indexdata.dk/cgi-bin/mailman/listinfo/yazlist
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.indexdata.dk/pipermail/yazlist/attachments/20201123/e7db3dad/attachment.html>


More information about the Yazlist mailing list