[Yazlist] Cannot Compile YAZ4J

Jakub Skoczen jakub at indexdata.dk
Tue Apr 1 18:30:11 UTC 2014


The problem is that the version of libyaz4 shipped with Debian/Ubuntu
is too old.

I've added a workaround -- do a 'git pull' in your yaz4j checkout and
you should be able to build it. In general it's best to use the libyaz
packages from Index Data's apt repository.

On Tue, Apr 1, 2014 at 7:26 PM, Odili Charles Opute <chaluwa at gmail.com> wrote:
> I am just starting out with YAZ4J and I am following the tutorial at
> http://goo.gl/RypnIA. I am running ubuntu 12, with Oracle JDK 1.7 and Maven
> 3. I have installed libyaz4-dev and swig and successfully executed git clone
> git://git.indexdata.com/yaz4j However I am not able to get beyond the "mvn
> install" because the maven build throws several errors which I have pasted
> here : http://ur1.ca/gyk44
>
> Please how do I proceed.
>
> --
> Kind Regards
> Odili Charles Opute
> Twitter : @chaluwa
> Author : http://goo.gl/v54jy
>
> _______________________________________________
> Yazlist mailing list
> Yazlist at lists.indexdata.dk
> http://lists.indexdata.dk/cgi-bin/mailman/listinfo/yazlist
>



-- 

Cheers,
Jakub



More information about the Yazlist mailing list