[Yazlist] Using 64bit YAZ on Windows

Dennis Schafroth dennis at indexdata.com
Wed Jun 6 11:30:37 CEST 2012


Hi, 

The first part is my mistake. The first functions has now been implemented in git. The second was misspelled in the implementation. 

On the second part, I cannot help, expect that you are right that we uses Visual Studio for development. Anyone else tried with mingw ? 

cheers, 
:-Dennis Schafroth

Index Data

On Jun 5, 2012, at 06:44 , David Nock wrote:

> 
> Hi,
> 
> Stepping back from the JNI side of things, I have been trying to get one of the zoom examples to compile and run.
> 
> I have installed the 64bit YAZ libraries (http://ftp.indexdata.dk/pub/yaz/win64/yaz_4.2.33.exe) and compiled code from zoomtst1.c.
> BTW, the yaz/zoom.h mentions 2 functions that don't appear to exist in the lib as I get undefined references to them:
> 
>    ZOOM_resultset_get_facet_field_by_index
>    ZOOM_resultset_facets_names
> 
> However, as soon as it hits ZOOM_connection_new, it crashes:
> 
> $ /cygdrive/c/mingw64/bin/gdb ./zoomtst1.exe
> GNU gdb (GDB) 7.1.90.20100730-cvs
> Copyright (C) 2010 Free Software Foundation, Inc.
> License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
> This is free software: you are free to change and redistribute it.
> There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
> and "show warranty" for details.
> This GDB was configured as "x86_64-w64-mingw32".
> For bug reporting instructions, please see:
> <http://www.gnu.org/software/gdb/bugs/>...
> Reading symbols from C:\Y\2/./zoomtst1.exe...done.
> (gdb) r bagel.indexdata.dk/gils computer
> Starting program: C:\Y\2/./zoomtst1.exe bagel.indexdata.dk/gils computer
> [New Thread 688.0x270]
> 
> Program received signal SIGSEGV, Segmentation fault.
> 0x00000000004016f0 in ZOOM_connection_new ()
> (gdb) bt
> #0  0x00000000004016f0 in ZOOM_connection_new ()
> #1  0x00000000004015ce in zoomtst1 (argc=3, argv=0x3e39b0) at zoomtst1.c:30
> (gdb) print argv[1]
> $1 = 0x3e3a50 "bagel.indexdata.dk/gils"
> (gdb) disassemble
> Dump of assembler code for function ZOOM_connection_new:
> => 0x00000000004016f0 <+0>:     jmpq   *0x40c2c0(%rip)        # 0x80d9b6
>   0x00000000004016f6 <+6>:     nop
>   0x00000000004016f7 <+7>:     nop
> End of assembler dump.
> (gdb) quit
> 
> I'm guessing that the libraries were built with Visual Studio and as this is just a C app/library, I wasn't thinking there should be a problem using mingw to build the app.
> This is what I have done previously for win32.
> 
> To try and get more info about what was happening, I tried compiling a debug version of yaz but that lead to a list of compilation errors relating to CONDITION_VARIABLE.
> 
> Hoping someone out there can help.
> 
> Thanks,
> Dave
> 
> 
> _______________________________________________
> Yazlist mailing list
> Yazlist at lists.indexdata.dk
> http://lists.indexdata.dk/cgi-bin/mailman/listinfo/yazlist
> 




More information about the Yazlist mailing list