[Yazlist] php5-yaz - Debian Squeeze

Steven Schwengel schwengel at hotmail.com
Thu Mar 24 22:58:18 CET 2011


Php5-yaz in Debian Squeeze works from Adam's git hub snapshot dated March 22, 2011http://git.indexdata.com/?p=phpyaz.git;a=summary

Note: if you did from scratch an installation of Debian Squeeze with just the first CD-1 install disk or download of the operating system, you'll probably need to install... debhelper and libyaz4-dev before the php5-yaz package. 
Many thanks Adam, you rock !Steven



Date: Tue, 22 Mar 2011 15:07:09 +0100
From: adam at indexdata.dk
To: yazlist at lists.indexdata.dk
Subject: Re: [Yazlist] php5-yaz - Debian Squeeze



  


    
  
  
    On 2011-03-22 03:54, Steven Schwengel wrote:
    
      
      Greetings.   
      Is there anyone who has been able to get
        PHP5-YAZ_1.0.7-2.i386 to work in Debian Squeeze? 

      
    
    We took 1.0.14 source and moved it to our Git SCM .. Changed debian
    building a bit.. This works for me on Ubuntu Maverick .. 

    

    Get it from here:

    

    http://git.indexdata.com/?p=phpyaz.git;a=summary

    

    (click on latest snapshot).

    

    tar zxf phpyaz-db6f7d5b6fe8d...*.tar.gz

    cd phpyaz

    dpkg-buildpackage -rfakeroot

    cd ..

    sudo dpkg -i php5-yaz_1.0.14-1indexdata_amd64.deb 

    

    Please let us know if you succeed on Debian squeeze.

    

    / Adam

    

    
      

      
      Unfortunately, I can't get PHP5-YAZ to work on Debian Squeeze
        (it is also not listed as Squeeze compatible on the IndexData
        website). I had upgraded to Squeeze (complete clean install) and
        PHPYAZ is not working for me.  Thankfully, my code was working
        in the previous version to test out... The error message upon
        trying to install in Debian Squeeze I'm getting on a i386 is:
        
          

          
          "
          php5-yaz is already the newest version.
          You might want to run 'apt-get' -f install' to correct
            these:
          The following packages have unmet dependencies:
            php5-yaz : Depends:  libyaz2 (>= 2.1.18) but is not
            installable
          E:Unmet Dependencies.  Try 'apt-get -f install'

            

            
            "
            

            
          
          So for, I have tried installing the software a couple of
            different methods from app-get to a command line install
            with dpkg and I have not had much luck... Also, I cannot
            find copy of libyaz2 or using the 'apt-get -f' install
            option as well does not bring me any closer. Any help would
            be great.  I'm willing to learn something new in order to
            track down what is up.  Any starter thoughts?  Hopefully I'm
            doing something wrong that can be fixed...  I'd rather not
            have to downgrade to Lenny, but I'm willing to downgrade it
            to fix my php-yaz installation problem.
        
        

        
        Many Thanks,
        Steven S.
        

        
      
      
_______________________________________________
Yazlist mailing list
Yazlist at lists.indexdata.dk
http://lists.indexdata.dk/cgi-bin/mailman/listinfo/yazlist

    
    

  


_______________________________________________
Yazlist mailing list
Yazlist at lists.indexdata.dk
http://lists.indexdata.dk/cgi-bin/mailman/listinfo/yazlist 		 	   		  
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.indexdata.dk/pipermail/yazlist/attachments/20110324/fc2e2669/attachment.htm>


More information about the Yazlist mailing list