[Yazlist] ruby-zoom no longer able to connect to Zebra

Walter McGinnis walter at katipo.co.nz
Wed Aug 3 23:18:00 CEST 2011


On Aug 3, 2011, at 12:11 PM, Walter McGinnis wrote:

> Hi again,
> 
> Ok, I found the problem. Or more accurately a workaround that allows me to get things working.
> 
> Turns out, at least on Debian Lenny, that unlike zoomsh and yaz-client, when running ruby-zoom's Zoom::Connection#connect specifying 'localhost' wouldn't even hit the Zebra instance (well, nothing noted in log) whereas '127.0.0.1' works fine.
> 
> The problem exists in YAZ 4.2.6 in combination with a recently updated Debian Lenny install.
> 
> I know that as late as YAZ 4.0.11 this wasn't a problem on Debian Lenny (though I can't be positive that it was all the way up to date).
> 
> It is very weird to me that it is specific to ruby-zoom and isn't a problem with yaz-client or zoomsh. Maybe an issue with updated Debian Lenny? Maybe something in YAZ?
> 

Turns out it isn't an issue with Squeeze though. So I guess it was a quirk of the various combination of YAZ and Debian Lenny updated to a certain point.

Oh well, off to upgrade things to Squeeze.

Cheers,
Walter


More information about the Yazlist mailing list