[Yazlist] changes to 3.0.26 to build with debian lenny

Daniel Kahn Gillmor dkg at fifthhorseman.net
Fri Feb 29 19:49:35 CET 2008


Hey folks--

Thanks for building and offering libyaz.  The lenny packages you're
offering now don't seem to be installable because of the libicu
transition.  The patch below (to debian/control) lets it build on
lenny for me.

You can read up on the recent libicu transition here:

  http://lists.alioth.debian.org/pipermail/pkg-webkit-maintainers/2007-November/000122.html

Regards,

        --dkg

--- yaz-3.0.26.orig/debian/control
+++ yaz-3.0.26/debian/control
@@ -3,7 +3,7 @@
 Standards-Version: 3.6.2
 Maintainer: Adam Dickmeiss <adam at indexdata.dk>
 Priority: extra
-Build-Depends: debhelper (>= 4), pkg-config, libxslt1-dev, libssl-dev, libreadline5-dev, libwrap0-dev, libicu36-dev | libicu38-dev
+Build-Depends: debhelper (>= 4), pkg-config, libxslt1-dev, libssl-dev, libreadline5-dev, libwrap0-dev, libicu-dev | libicu36-dev | libicu38-dev
 
 Package: libyaz3
 Section: libs
@@ -37,7 +37,7 @@
  This packages includes HTML documentation for YAZ.
 
 Package: libyaz3-dev
-Depends: libyaz3 (= ${Source-Version}), libxslt1-dev, libwrap0-dev, libssl-dev, libicu36-dev|libicu38-dev, tcl8.3|tclsh
+Depends: libyaz3 (= ${Source-Version}), libxslt1-dev, libwrap0-dev, libssl-dev, libicu-dev|libicu36-dev|libicu38-dev, tcl8.3|tclsh
 Replaces: yaz-devel
 Conflicts: yaz-devel, libyaz-dev, libyaz2-dev
 Section: libdevel


-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 826 bytes
Desc: not available
Url : http://lists.indexdata.dk/pipermail/yazlist/attachments/20080229/80417288/attachment.pgp 


More information about the Yazlist mailing list