[Yazlist] PHP-YAZ problem: Initialization failed

Adam Dickmeiss adam at indexdata.dk
Fri Oct 5 06:16:37 CEST 2001


On Thu, Oct 04, 2001 at 12:56:22PM +0200, Ocetkiewicz András wrote:
> Hello,
> I've been developing a PHP/YAZ based z client and  found difficulties to
> connect to one specific type of Z server with it. This kind of Z server is
> distributed with OLIB.
> Its parameters are:
> Z39.50 vers.: 3
> Implementation name: Index Data/YAZ Generic Frontend Server
> Implementation version: 1.14.pl2+
> Anyway is it a Z'mbol server?

Probably not. OLIB provides its own gateway build on top of YAZ.

> I tried three instances of this kind of  Z server (at different locations)
> with the following outcome:
> 2 servers gave back error messages: Initatlization failed
> They both worked well with ICONE and a YAZ based command line client.

Assuming that the InitRequest is really what upsets the server(s) I'd guess
that the problem is related to Z39.50 options or authentication settings.
Do these servers require a password?

> 1 server answered: 0 hits to every kind of request even when I tried it with
> ICONE (the attribute I used was supported)
So that ONE server returns 0 for all requests from ICONE and PHP/YAZ but
not YAZ command client? Anyway, there are several things that can go wrong
with queries. Are you firing off the exact same queries to all servers?

> Do you have any idea about what can cause the problem?

Do you have addresses for those servers? That would make it easier
to help you on this.

Cheers,
   Adam

> Budapest University of Technology and Economics
> Andras Ocetkiewicz



More information about the Yazlist mailing list