[Net-z3950] Error compiling SimpleServer 1.07

Phil Cross phil.cross at bristol.ac.uk
Fri Sep 7 16:56:02 CEST 2007


I'm trying to compile SimpleServer 1.07 against yaz version 3.0.10 on a 
solaris 2.9 system. Both the yaz and perl installations are in 
non-standard places, but I edited the $yazconf value in Makefile.PL to 
reflect this.

I had managed to install SimpleServer 1.05 ok against yaz version 2.1.48 
on the same machine.

I get the following error when running 'make':



gcc -c  -I/home/project/yaz-3.0.10/local/include -DYAZ_HAVE_XML2=1 
-DYAZ_HAVE_XSLT=1 -I/usr/include/libxml2  -fno-strict-aliasing -pipe 
-I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -O 
-DVERSION=\"1.07\"  -DXS_VERSION=\"1.07\" -fPIC 
"-I/home/project/perl5.8.8/lib/5.8.8/sun4-solaris/CORE"   SimpleServer.c
SimpleServer.xs: In function `apt2perl':
SimpleServer.xs:428: parse error before `*'
SimpleServer.xs:431: `c' undeclared (first use in this function)
SimpleServer.xs:431: (Each undeclared identifier is reported only once
SimpleServer.xs:431: for each function it appears in.)
SimpleServer.xs:432: `son' undeclared (first use in this function)
*** Error code 1
make: Fatal error: Command failed for target `SimpleServer.o'



Any ideas?

Best wishes,

-- 
---------------------------------
Phil Cross
Senior Technical Researcher
Institute for Learning and Research Technology
University of Bristol
8 - 10 Berkeley Square
Bristol, BS8 1HH
Tel: +44 (0)117 928 7067
Fax: +44 (0)117 928 7112
E-mail: phil.cross at bristol.ac.uk
URL: http://www.ilrt.bris.ac.uk/aboutus/staff?search=cmpac
-----------------------------------




More information about the Net-z3950 mailing list