[Net-z3950] Expected CONSTRUCTED PDU not found

Adam Dickmeiss adam at indexdata.dk
Thu May 26 20:28:56 CEST 2005


Mike Taylor wrote:
>>Date: Thu, 26 May 2005 12:45:52 -0500
>>From: "Marvin Hunn" <MHunn at dts.edu>
>>
>>I have just installed the perl module Net::Z3950 and am attempting
>>to search our local library zserver. I am able to connect and
>>execute a search and get the number of records that match (4 in this
>>case), but when I attempt to retrieve a record, I get an error:
>>"Expected CONSTRUCTED PDU not found"
> 
> 
> Eek!
> 
Here is another one where YAZ throws a diagnostic.

Z> f computer
Sent searchRequest.
Received SearchResponse.
Search was a success.
Number of hits: 613, setno 1
records returned: 0
Elapsed: 0.175270
Z> s
Sent presentRequest (1+1).
Decoding incoming APDU: Protocol error (code 7:19)
[Near 43]
Packet dump:
---------
     0: [25] len=1875       tl=1, ll=3 cons=1
     4:     [24] len=1       tl=1, ll=1 cons=0
     7:     [25] len=1       tl=1, ll=1 cons=0
    10:     [27] len=1       tl=1, ll=1 cons=0
    13:     [28] len=1862       tl=1, ll=3 cons=1
    17:         SEQUENCE len=1858       tl=1, ll=3 cons=1
    21:             [0] len=7       tl=1, ll=1 cons=0
    30:             [1] len=1845       tl=1, ll=3 cons=1
    34:                 [1] len=1841       tl=1, ll=3 cons=1
    38:                     EXTERNAL len=1837       tl=1, ll=3 cons=1
    42:                         OID len=0       tl=1, ll=1 cons=0
    44:                         [1] len=1831       tl=1, ll=3 cons=0
---------
Elapsed: 0.374536



> 
>>We have a Bath compliant Sirsi Unicorn zserver at: library.dts.edu:2200

But is it BER compliant :-)

/ Adam





More information about the Net-z3950 mailing list