[Net-z3950] Runtime-error/make test hangs

Mike Taylor mike at seatbooker.net
Fri Aug 16 12:41:47 CEST 2002


> Date: Fri, 16 Aug 2002 12:26:12 +0200 (CEST)
> From: =?ISO-8859-1?Q?Anders_S=F8nderberg_Mortensen?= <sondberg at indexdata.dk>
> 
> After we upgraded a rh-box to use perl 5.6.0, some problems
> occured. The first thing I noticed was, that when I compile
> Net::Z3950 with Event-0.80 or Event-0.86, the make test hangs after
> the "ok 6" has appeared.

Hi Anders.  I'm running Red Hat 7.1 (Seawolf) pretty much out of the
box, with its 2.4.2-2 kernel.  That comes with Perl 5.6.0 which I'm
also using.  I've just downloaded, build, tested and installed Event
v0.86 with no problems, and rebuild, tested and installed Net::Z3950
v0.30 (the current distributed version) also with no problem.  So it
looks like there may be something screwy on your system.

Can you try it on a vanilla RH7.1 box?

> I tried to ignore this, but then later I got this run-time error:
> 
> Event: '?? Connection.pm:134' died and then $Event::DIED died with: Can't 
> call method "attributes" without a package or object reference at 
> /usr/lib/perl5/site_perl/5.6.0/i386-linux/Event.pm line 88.
> 
>  at /usr/lib/perl5/site_perl/5.6.0/i386-linux/Net/Z3950/Manager.pm line 
> 220
> Use of uninitialized value in concatenation (.) at 
> /usr/lib/perl5/site_perl/5.6.0/i386-linux/Event.pm line 86.
> 
> Anyone seen this?

Nope, sorry.

> I've attached the package (Multiplex.pm), by which I call the 
> Net::Z3950 methods.

There's not enough there for me to actually run the code.  Can you
send me a minimal framework that creates and deploys a Multiplex in
such a way as to exercise this bug on your system?

Thanks,

 _/|_	 _______________________________________________________________
/o ) \/  Mike Taylor   <mike at miketaylor.org.uk>   www.miketaylor.org.uk
)_v__/\  "Personally, I don't think its sexual dimorphism.  I'm all
	 for it, but not in this case" - Tracy L. Ford.





More information about the Net-z3950 mailing list