Mike Taylor [Fri, 21 Mar 2014 12:49:50 +0000 (12:49 +0000)]
Reorder some functions.
Mike Taylor [Fri, 21 Mar 2014 12:48:42 +0000 (12:48 +0000)]
redrawNavi was a one-line function invoked in only one place.
Inline it.
Mike Taylor [Fri, 21 Mar 2014 12:48:15 +0000 (12:48 +0000)]
Switch order of resetPage/redrawNavi invocations.
Mike Taylor [Fri, 21 Mar 2014 12:47:35 +0000 (12:47 +0000)]
Every single invocation of triggerSearch was preceded by invocations
of redrawNavi and resetPage. I removed those invocations and now
triggerSearch itself starts by invoking them.
Mike Taylor [Fri, 21 Mar 2014 12:44:19 +0000 (12:44 +0000)]
loadSelect is removed: no longer needed.
Mike Taylor [Fri, 21 Mar 2014 12:34:56 +0000 (12:34 +0000)]
onSortChange and onPerpageChange set their member variables directly.
loadSelect() is now just an assertion that things are set correctly.
Mike Taylor [Fri, 21 Mar 2014 12:11:26 +0000 (12:11 +0000)]
Break mkwsResults down to its components.
Use jQuery 1.11, to avoid stupid "event.returnValue is
deprecated. Please use the standard event.preventDefault() instead"
warning.
Mike Taylor [Fri, 21 Mar 2014 11:00:06 +0000 (11:00 +0000)]
Split onSelectDdChange into two separate functions, onSortChange and onPerpageChange.
Prepares the way for pub/sub widgetising those controls.
Mike Taylor [Thu, 20 Mar 2014 11:56:32 +0000 (11:56 +0000)]
Remove unnecessary test.
Mike Taylor [Thu, 20 Mar 2014 11:46:43 +0000 (11:46 +0000)]
Comment typo
Mike Taylor [Thu, 20 Mar 2014 11:11:09 +0000 (11:11 +0000)]
Simplify
Mike Taylor [Thu, 20 Mar 2014 10:14:32 +0000 (10:14 +0000)]
Reimplement the Navi widget with pub/sub.
Mike Taylor [Thu, 20 Mar 2014 09:49:57 +0000 (09:49 +0000)]
Widget-promotion switch is now driven by a table.
Avoids repetitive code, and enables external extensions.
Mike Taylor [Thu, 20 Mar 2014 09:49:18 +0000 (09:49 +0000)]
Make renderDetails() available as team member-function.
Mike Taylor [Thu, 20 Mar 2014 09:46:52 +0000 (09:46 +0000)]
Comment out unnecessarily noisy test/spec/mkws-pazpar2.js logging.
Mike Taylor [Wed, 19 Mar 2014 17:57:56 +0000 (17:57 +0000)]
More explicit logging for widget-creation
Mike Taylor [Wed, 19 Mar 2014 17:02:48 +0000 (17:02 +0000)]
Team-specific debug function now visible as team.debug.
This is used in the widget constructor.
Mike Taylor [Wed, 19 Mar 2014 16:50:28 +0000 (16:50 +0000)]
Fix rendering of team-name in widget-creation logging.
Mike Taylor [Wed, 19 Mar 2014 16:45:13 +0000 (16:45 +0000)]
Move Records widget into its own object.
Needs two more team accessor methods:
currentRecordId, currentRecordData
I'm not really happy about these, as that data properly belongs to the
widget. But at the moment, they're still used by team.showDetails, so
they can't be moved yet.
Mike Taylor [Wed, 19 Mar 2014 16:07:27 +0000 (16:07 +0000)]
Simplify.
Mike Taylor [Wed, 19 Mar 2014 15:56:36 +0000 (15:56 +0000)]
Move pager code into its own object.
To support this add three new accessor methods to the team object:
perpage, totalRecordCount, currentPage
Mike Taylor [Tue, 18 Mar 2014 17:40:56 +0000 (17:40 +0000)]
Clarify comment.
Mike Taylor [Tue, 18 Mar 2014 17:40:40 +0000 (17:40 +0000)]
Fix comment.
Mike Taylor [Tue, 18 Mar 2014 17:40:05 +0000 (17:40 +0000)]
Termlists widget reimplenented using pub/sub.
Mike Taylor [Tue, 18 Mar 2014 17:39:29 +0000 (17:39 +0000)]
Walk across all MKWS nodes twice: once to make teams, then to make widgets.
It has to be done in two passes because the first pass has the
side-effect of creating some widget elements, e.g. mkwsResults has
mkwsTermlists created within it.
So far, no functional differences.
Mike Taylor [Tue, 18 Mar 2014 16:47:32 +0000 (16:47 +0000)]
Revert mike.html to a vanilla search UI.
Wolfram Schneider [Tue, 18 Mar 2014 15:43:46 +0000 (15:43 +0000)]
Merge branch 'master' of ssh://git.indexdata.com:222/home/git/private/mkws
Wolfram Schneider [Tue, 18 Mar 2014 15:43:37 +0000 (15:43 +0000)]
fix typo in last commit
Wolfram Schneider [Tue, 18 Mar 2014 15:41:22 +0000 (15:41 +0000)]
check for single active client before clicking on a record
Mike Taylor [Tue, 18 Mar 2014 14:28:20 +0000 (14:28 +0000)]
Rename member variable m_curDetRecData to m_currentRecordData.
Fixes the last part of MKWS-123.
Mike Taylor [Tue, 18 Mar 2014 14:26:52 +0000 (14:26 +0000)]
Rename member variable m_curDetRecId to m_currentRecordId.
Fixes part of MKWS-123.
Mike Taylor [Tue, 18 Mar 2014 14:25:14 +0000 (14:25 +0000)]
Rename local variable.
Mike Taylor [Tue, 18 Mar 2014 14:09:14 +0000 (14:09 +0000)]
Rename m_curPage to m_currentPage.
Fixes part of MKWS-123
Mike Taylor [Tue, 18 Mar 2014 14:07:38 +0000 (14:07 +0000)]
Rename m_totalRec to m_totalRecordCount
Mike Taylor [Tue, 18 Mar 2014 12:47:31 +0000 (12:47 +0000)]
Merge branch 'master' of ssh://git.indexdata.com/home/git/private/mkws
Mike Taylor [Tue, 18 Mar 2014 12:45:30 +0000 (12:45 +0000)]
Rename m_debug_time to m_debugTime.
Mike Taylor [Tue, 18 Mar 2014 12:44:40 +0000 (12:44 +0000)]
Rename "sort" parameter to "sortOrder" in functions newSearch and triggerSearch.
Rename "sort" local variable to "sortOrder" in function runAutoSearch.
Mike Taylor [Tue, 18 Mar 2014 12:40:26 +0000 (12:40 +0000)]
Rename m_sort member variable to m_sortOrder
Wolfram Schneider [Tue, 18 Mar 2014 09:59:02 +0000 (09:59 +0000)]
Fix Check status client counter check
jasmine run() must be called after waitsFor()
Wolfram Schneider [Tue, 18 Mar 2014 09:55:56 +0000 (09:55 +0000)]
cleanup .unbind() code
Wolfram Schneider [Tue, 18 Mar 2014 09:51:27 +0000 (09:51 +0000)]
Merge branch 'master' of ssh://git.indexdata.com:222/home/git/private/mkws
Conflicts:
tools/htdocs/mkws-jquery.js
Wolfram Schneider [Tue, 18 Mar 2014 09:49:55 +0000 (09:49 +0000)]
improve javascript object check from last commit
Wolfram Schneider [Mon, 17 Mar 2014 20:39:56 +0000 (20:39 +0000)]
wait for stat() change in DOM, MKWS-139
Mike Taylor [Mon, 17 Mar 2014 17:30:47 +0000 (17:30 +0000)]
pazpar2() extension uses an empty config object if nothing is passed
in. Fixes bug MKWS-95 properly.
Mike Taylor [Mon, 17 Mar 2014 17:30:15 +0000 (17:30 +0000)]
Merge branch 'master' of ssh://git.indexdata.com/home/git/private/mkws
Mike Taylor [Mon, 17 Mar 2014 17:30:11 +0000 (17:30 +0000)]
New mike.html, tests jQuery plugin.
Wolfram Schneider [Mon, 17 Mar 2014 14:23:12 +0000 (14:23 +0000)]
allow hostnames with dash ("-"), e.g mkc-cproxy.indexdata.com
Mike Taylor [Mon, 17 Mar 2014 12:35:51 +0000 (12:35 +0000)]
Merge branch 'master' of ssh://git.indexdata.com/home/git/private/mkws
Mike Taylor [Mon, 17 Mar 2014 12:35:47 +0000 (12:35 +0000)]
Fix typo.
Wolfram Schneider [Mon, 17 Mar 2014 08:01:04 +0000 (08:01 +0000)]
fix HANDLEBARS_URL value
Wolfram Schneider [Mon, 17 Mar 2014 07:45:16 +0000 (08:45 +0100)]
fetching a file from the Internet must be atomar
Wolfram Schneider [Sun, 16 Mar 2014 13:07:15 +0000 (13:07 +0000)]
add perltidy target
Wolfram Schneider [Sun, 16 Mar 2014 13:04:26 +0000 (13:04 +0000)]
increase timeout to 16 seconds
Wolfram Schneider [Fri, 14 Mar 2014 18:13:30 +0000 (18:13 +0000)]
ASCII dump of HTML page (not fully implemented yet).
Wolfram Schneider [Fri, 14 Mar 2014 14:25:08 +0000 (14:25 +0000)]
use new script phantom/run-jasmine.js
Wolfram Schneider [Fri, 14 Mar 2014 14:21:42 +0000 (14:21 +0000)]
rewrite test to display better error messages and avoid race conditions, MKWS-135
Wolfram Schneider [Thu, 13 Mar 2014 11:13:40 +0000 (11:13 +0000)]
IE8 does not support DOMSubtreeModified, use propertychange, MKWS-77
see http://stackoverflow.com/questions/
19869547/domsubtreemodified-equivalent-in-ie
Wolfram Schneider [Thu, 13 Mar 2014 11:03:47 +0000 (11:03 +0000)]
IE8 does not support the map() function, and we have to use the jquery $.map(), MKWS-77
Wolfram Schneider [Mon, 10 Mar 2014 14:52:59 +0000 (14:52 +0000)]
./bomb.pl will use the slightly larger timeout as the node.js script (was fixed 100 seconds)
Wolfram Schneider [Mon, 10 Mar 2014 14:32:53 +0000 (14:32 +0000)]
Merge branch 'master' of ssh://git.indexdata.com:222/home/git/private/mkws
Wolfram Schneider [Mon, 10 Mar 2014 14:23:13 +0000 (14:23 +0000)]
Check for DOMSubtreeModified and a first link
some browser sents 2 DOMSubtreeModified events, other only one. Make
sure it will works for both, and check for the first link too.
Heikki Levanto [Mon, 10 Mar 2014 14:10:51 +0000 (15:10 +0100)]
whitespace
Wolfram Schneider [Mon, 10 Mar 2014 13:59:01 +0000 (13:59 +0000)]
wait for new records HTML data before we click on a record, MKWS-137
If we click on a limit source link we have to wait until the pz2 show()
record request returns fresh data from the new result set. This is
implemented by the DOMSubtreeModified event.
Heikki Levanto [Mon, 10 Mar 2014 11:52:56 +0000 (12:52 +0100)]
Merge branch 'master' of ssh://git.indexdata.com:222/home/git/private/mkws
Heikki Levanto [Mon, 10 Mar 2014 11:52:50 +0000 (12:52 +0100)]
One small comment
Wolfram Schneider [Mon, 10 Mar 2014 10:40:22 +0000 (10:40 +0000)]
LoC has records without links, in that case the test should not fail
Wolfram Schneider [Fri, 7 Mar 2014 17:47:46 +0000 (17:47 +0000)]
typo in help message
Wolfram Schneider [Fri, 7 Mar 2014 17:22:17 +0000 (17:22 +0000)]
remove support for older jquery version
Wolfram Schneider [Fri, 7 Mar 2014 17:21:29 +0000 (17:21 +0000)]
Minimum jquery version is now 1.7.2 (was 1.6.4)
Wolfram Schneider [Fri, 7 Mar 2014 17:13:04 +0000 (17:13 +0000)]
add mkwsMOTD
Wolfram Schneider [Fri, 7 Mar 2014 17:06:52 +0000 (17:06 +0000)]
fix xpath for URL extract check
Wolfram Schneider [Fri, 7 Mar 2014 16:54:58 +0000 (16:54 +0000)]
alias p -> phantomjs
Wolfram Schneider [Fri, 7 Mar 2014 16:54:03 +0000 (16:54 +0000)]
less debugging noise
Wolfram Schneider [Fri, 7 Mar 2014 16:51:12 +0000 (16:51 +0000)]
if there are no "good" sources, ignore the source facet check. MKWS-137
Wolfram Schneider [Fri, 7 Mar 2014 16:43:34 +0000 (16:43 +0000)]
refactor: make a new test "Check record list", called before "Show record"
Wolfram Schneider [Fri, 7 Mar 2014 16:42:30 +0000 (16:42 +0000)]
indent
Heikki Levanto [Fri, 7 Mar 2014 15:01:32 +0000 (16:01 +0100)]
Detect the case when no author is good enough to click. MKWS-137
Detects and logs the situation. Unfortunately, when that happens,
the next test seems to fail...
Heikki Levanto [Fri, 7 Mar 2014 14:32:42 +0000 (15:32 +0100)]
Fix race condition in "Show record" MKWS-137
Heikki Levanto [Fri, 7 Mar 2014 12:45:36 +0000 (13:45 +0100)]
Merge branch 'master' of ssh://git.indexdata.com:222/home/git/private/mkws
Conflicts:
test/spec/mkws-pazpar2.js
Heikki Levanto [Fri, 7 Mar 2014 12:43:57 +0000 (13:43 +0100)]
Do note test return value of .trigger("click")
It should return this, but seems that some times it does not.
Anyway, that test is not really testing our things. The
subsequent tests on content and visibility should catch a missed
click anyway.
Heikki Levanto [Fri, 7 Mar 2014 12:40:03 +0000 (13:40 +0100)]
Do not test the return value of .trigger("click")
The tirgger() is supposed to return this, but seems not to do
so always. The subsequent tests confirm that the click event
has happened anyway.
If the click event does not happen for some reason, the next
tests will fail, so I believe the testing is as good.
Heikki Levanto [Fri, 7 Mar 2014 12:39:28 +0000 (13:39 +0100)]
More about setting up apache
needed to do this to work on my home machine, so I documented
what was needed.
Wolfram Schneider [Fri, 7 Mar 2014 10:25:49 +0000 (10:25 +0000)]
add a prefix for jasmine console log messages
Wolfram Schneider [Fri, 7 Mar 2014 10:15:35 +0000 (10:15 +0000)]
Unit tests for the MOTD MKWS-134
Heikki Levanto [Thu, 6 Mar 2014 14:43:25 +0000 (15:43 +0100)]
Unit tests for the MOTD MKWS-134
Added tests for the MOTD being moved to the right place before search
and not being visible after search. Temporarily broke the code to
verify my tests.
Heikki Levanto [Wed, 5 Mar 2014 14:35:21 +0000 (15:35 +0100)]
Minor comment about environment
Mike Taylor [Wed, 5 Mar 2014 10:04:16 +0000 (10:04 +0000)]
Automatic termlist widgets now work:
<div id='mkwsTermlists' autosearch='dinosaur' sort='relevance'></div>
Mike Taylor [Wed, 5 Mar 2014 09:57:09 +0000 (09:57 +0000)]
Mike's playground reverted to an auto-widget.
Mike Taylor [Wed, 5 Mar 2014 09:54:45 +0000 (09:54 +0000)]
Remove redundant utility function mkws.parseQuerystring().
Use mkws.getParameterByName() instead.
Mike Taylor [Wed, 5 Mar 2014 09:46:25 +0000 (09:46 +0000)]
Rewrite comment.
Mike Taylor [Wed, 5 Mar 2014 09:45:03 +0000 (09:45 +0000)]
Move URL-parsing utility functions out of the team.
Mike Taylor [Wed, 5 Mar 2014 09:33:38 +0000 (09:33 +0000)]
Move mkws.defaultTemplate() out of the team structure.
Fixes part of MKWS-126.
Mike Taylor [Wed, 5 Mar 2014 09:25:16 +0000 (09:25 +0000)]
Fix whitespace.
Mike Taylor [Wed, 5 Mar 2014 09:24:33 +0000 (09:24 +0000)]
Remove ALL ID-based targets from CSS.
Fixes the last part of MWKS-117.
Mike Taylor [Wed, 5 Mar 2014 09:19:41 +0000 (09:19 +0000)]
Set full-record HTML using jQuery rather than innerHTML.
Fixes the last part of MKWS-22.
Mike Taylor [Tue, 4 Mar 2014 17:21:23 +0000 (17:21 +0000)]
Change Mike's playground to two-team version.
Mike Taylor [Tue, 4 Mar 2014 17:13:23 +0000 (17:13 +0000)]
Comment.
Mike Taylor [Tue, 4 Mar 2014 17:11:19 +0000 (17:11 +0000)]
Move event-queue code into teams.
Events are now subscribed/published on team-specific basis.
As a result, we don't need the ugly faceted event names.
Mike Taylor [Tue, 4 Mar 2014 16:48:16 +0000 (16:48 +0000)]
stat event-queueing is per-team.
Mike Taylor [Tue, 4 Mar 2014 15:24:31 +0000 (15:24 +0000)]
New team member-function, name().
"targets" events are now registered per-team.