Mike Taylor [Thu, 13 Feb 2014 11:26:48 +0000 (11:26 +0000)]
New file, mike.html -- local version of popup.html
Mike Taylor [Thu, 13 Feb 2014 11:25:17 +0000 (11:25 +0000)]
Rename
Mike Taylor [Thu, 13 Feb 2014 10:56:06 +0000 (10:56 +0000)]
Add logging for popup.
Mike Taylor [Thu, 13 Feb 2014 08:46:00 +0000 (08:46 +0000)]
New file auto-paratext.html, demo for Seb
Mike Taylor [Wed, 12 Feb 2014 18:40:28 +0000 (18:40 +0000)]
Initialise debug_level to 1 so that the jQuery popup can use it.
There's a better way to fix this by doing things in the right order,
but right now I need the logging to fix a different bug.
Mike Taylor [Wed, 12 Feb 2014 18:12:50 +0000 (18:12 +0000)]
All styles are now applicable by class as well as by ID.
Fixes the first half of MKWS-117.
(The second half is to dump the ID rules.)
Mike Taylor [Wed, 12 Feb 2014 18:01:14 +0000 (18:01 +0000)]
Remove no-longer-needed debugging output.
Mike Taylor [Wed, 12 Feb 2014 17:54:17 +0000 (17:54 +0000)]
Fix redundant local overrides of jQuery plugin default configuration values with copies of those values, to now use the new versions of those default values that rely on class selection rather than ID selection. It would make more sense to get rid of these pointless and error-prone overrides completely.
Mike Taylor [Wed, 12 Feb 2014 17:52:59 +0000 (17:52 +0000)]
Tweak dictionary-lookup example to work correctly without using IDs.
Mike Taylor [Wed, 12 Feb 2014 17:50:24 +0000 (17:50 +0000)]
mkws-jquery.js's default selectors for id_button and id_popup now use
classes rather than identifiers. I suppose this is, sort of, a part of
MKWS-116.
Mike Taylor [Wed, 12 Feb 2014 17:48:55 +0000 (17:48 +0000)]
Many more tests are now done using class selectors instead of IDs.
Regression-test now succeeds again.
Fixes the last part of MKWS-116.
Mike Taylor [Wed, 12 Feb 2014 17:21:08 +0000 (17:21 +0000)]
Move IDs from generated HTML.
Fixes most of bug MKWS-116.
But I'll need to also fix the regression-test to cope.
Mike Taylor [Wed, 12 Feb 2014 17:18:34 +0000 (17:18 +0000)]
Remove extraneous comment.
I seem to be doing this a lot.
Mike Taylor [Wed, 12 Feb 2014 16:19:47 +0000 (16:19 +0000)]
Add boolean target_filtered() function.
When true, no facet action is generated.
Fixes bug MKWS-111.
Mike Taylor [Wed, 12 Feb 2014 15:47:19 +0000 (15:47 +0000)]
Include mkws-jquery.js
Mike Taylor [Wed, 12 Feb 2014 15:47:14 +0000 (15:47 +0000)]
Include mkws-jquery.js
Mike Taylor [Wed, 12 Feb 2014 15:46:35 +0000 (15:46 +0000)]
Move jQuery plugin out of mkws.js into its own file mkws-jquery.js: see MKWS-120
Mike Taylor [Wed, 12 Feb 2014 15:22:41 +0000 (15:22 +0000)]
mkwsDet_* and mkwsRecdiv_* IDs include teamName.
This ensures the right instance of the record is expanded.
Mike Taylor [Wed, 12 Feb 2014 12:42:27 +0000 (12:42 +0000)]
Don't bother calculating result summary if there's no mkwsRecords
element.
Mike Taylor [Wed, 12 Feb 2014 12:41:08 +0000 (12:41 +0000)]
Remove wildly inaccurate comment.
Mike Taylor [Wed, 12 Feb 2014 12:09:50 +0000 (12:09 +0000)]
Address mkwsPrev and mkwsNext by class.
Mike Taylor [Wed, 12 Feb 2014 12:09:35 +0000 (12:09 +0000)]
Replace mkwsPrev/mkwsNext IDs with classes. See MKWS-115.
These classes are not needed by the MKWS code, but are made available
so they can be styled.
(Also the Jasmine test-suite uses them.)
Mike Taylor [Tue, 11 Feb 2014 17:24:00 +0000 (17:24 +0000)]
Fix test-suite's debug() function to use mkws.debug()
Mike Taylor [Tue, 11 Feb 2014 17:13:27 +0000 (17:13 +0000)]
Add a TODO comment.
Mike Taylor [Tue, 11 Feb 2014 17:07:40 +0000 (17:07 +0000)]
Remove misleading comment.
Mike Taylor [Tue, 11 Feb 2014 17:05:50 +0000 (17:05 +0000)]
Remove the misleadingly named domReady() function, and put its code
inline in its only caller.
Mike Taylor [Tue, 11 Feb 2014 16:31:56 +0000 (16:31 +0000)]
The third debug() function in mkws.js, inside the jQuery plugin, is
now also reduced to a one-line delegation to mkws.debug(). Nice to be
down to a single logging function.
Mike Taylor [Tue, 11 Feb 2014 16:25:49 +0000 (16:25 +0000)]
Get rid of log() function within global top-level code.
Now uses debug(), a local alias for mkws.debug().
Mike Taylor [Tue, 11 Feb 2014 16:24:05 +0000 (16:24 +0000)]
Rename mkws.debug_function() to mkws.debug()
Mike Taylor [Tue, 11 Feb 2014 16:23:26 +0000 (16:23 +0000)]
Move mkws.debug_function() lexically outside the team.
Mike Taylor [Tue, 11 Feb 2014 16:18:19 +0000 (16:18 +0000)]
Remove outdated comments.
Mike Taylor [Tue, 11 Feb 2014 16:18:00 +0000 (16:18 +0000)]
Separate out team-specific parts of mkws.debug_function() into inner
function debug() (which is now an actual wrapper function rather than
a mere alias).
Mike Taylor [Tue, 11 Feb 2014 15:24:33 +0000 (15:24 +0000)]
Remove extraneous declaration.
Mike Taylor [Tue, 11 Feb 2014 13:36:15 +0000 (13:36 +0000)]
Rewrite comment for global mkws object.
Mike Taylor [Tue, 11 Feb 2014 13:35:28 +0000 (13:35 +0000)]
Move and rewrite comment on member functions.
Mike Taylor [Tue, 11 Feb 2014 12:41:55 +0000 (12:41 +0000)]
Remove obsolete comment.
Mike Taylor [Tue, 11 Feb 2014 12:40:00 +0000 (12:40 +0000)]
pagerPrev() and pagerNext() made team-aware.
Mike Taylor [Tue, 11 Feb 2014 12:07:22 +0000 (12:07 +0000)]
Navigation to individual pages made team-aware.
Mike Taylor [Tue, 11 Feb 2014 11:52:04 +0000 (11:52 +0000)]
Remove immediately-overridden initial value of m_perpage.
Mike Taylor [Tue, 11 Feb 2014 11:39:10 +0000 (11:39 +0000)]
mkws_html_perpage() preserves current value of m_perpage() rather than
resetting to mkws_config.perpage_default.
Mike Taylor [Tue, 11 Feb 2014 11:35:36 +0000 (11:35 +0000)]
Rename m_recPerPage to m_perpage.
Mike Taylor [Tue, 11 Feb 2014 11:31:45 +0000 (11:31 +0000)]
Remove immediately-overridden initial value of m_sort.
Mike Taylor [Tue, 11 Feb 2014 11:31:17 +0000 (11:31 +0000)]
Sorting and records-per-page selection now team-aware.
Better logging.
Wolfram Schneider [Tue, 11 Feb 2014 10:04:03 +0000 (10:04 +0000)]
Merge branch 'master' of ssh://git.indexdata.com:222/home/git/private/mkws
Wolfram Schneider [Tue, 11 Feb 2014 10:02:58 +0000 (10:02 +0000)]
front end proxy for example-dev.indexdata.com/
Wolfram Schneider [Tue, 11 Feb 2014 09:59:24 +0000 (09:59 +0000)]
This is for the example-dev.indexdata.com, running on dart
Wolfram Schneider [Tue, 11 Feb 2014 09:57:17 +0000 (09:57 +0000)]
Merge branch 'master' of ssh://git.indexdata.com:222/home/git/private/mkws
Wolfram Schneider [Tue, 11 Feb 2014 09:53:14 +0000 (09:53 +0000)]
move apache example config from tools/apache2 to examples/apache2
Wolfram Schneider [Tue, 11 Feb 2014 09:46:36 +0000 (09:46 +0000)]
HTTPS config for example-dev.indexdata.com, MKWS-102
Wolfram Schneider [Tue, 11 Feb 2014 09:42:39 +0000 (09:42 +0000)]
Use protocol-relative URLs, MKWS-102
for links from http[s]://mkws.indexdata.com to http[s]://example.indexdata.com/
Wolfram Schneider [Tue, 11 Feb 2014 09:35:42 +0000 (09:35 +0000)]
HTTPS config for example.indexdata.com, MKWS-102
Mike Taylor [Mon, 10 Feb 2014 20:39:16 +0000 (20:39 +0000)]
Remove use of local SP
Wolfram Schneider [Mon, 10 Feb 2014 18:00:50 +0000 (18:00 +0000)]
Facet-related elements are identified by class rather than ID.
I was wondering why the tests often failed and didn't ignored the wikipedia
targets. This complete
17f6e251e4cceb61561611ebbf3c2f34ac3142d7
Wolfram Schneider [Mon, 10 Feb 2014 17:41:07 +0000 (17:41 +0000)]
Merge branch 'master' of ssh://git.indexdata.com:222/home/git/private/mkws
Mike Taylor [Mon, 10 Feb 2014 17:02:00 +0000 (17:02 +0000)]
Towards team-aware sorting.
Wolfram Schneider [Fri, 7 Feb 2014 22:06:12 +0000 (23:06 +0100)]
spaces
to make cut&paste of an URL easier
Mike Taylor [Fri, 7 Feb 2014 17:28:57 +0000 (17:28 +0000)]
Pager is now team-aware, hurrah!
Mike Taylor [Fri, 7 Feb 2014 17:24:45 +0000 (17:24 +0000)]
drawPager() now simply returns a string.
Mike Taylor [Fri, 7 Feb 2014 17:23:57 +0000 (17:23 +0000)]
Page element selection is done by jQuery.
Mike Taylor [Fri, 7 Feb 2014 17:23:10 +0000 (17:23 +0000)]
Simplify pager-text generation.
(It's still pretty darned opaque, though.)
Mike Taylor [Fri, 7 Feb 2014 17:20:09 +0000 (17:20 +0000)]
Remove meaningless comment.
Mike Taylor [Fri, 7 Feb 2014 17:19:56 +0000 (17:19 +0000)]
Better division of labour for drawPager()
Mike Taylor [Fri, 7 Feb 2014 16:03:55 +0000 (16:03 +0000)]
Remove old, no-longer-needed logging.
Mike Taylor [Fri, 7 Feb 2014 15:57:38 +0000 (15:57 +0000)]
Move mkws.switchView() outside of the team object, have it invoke the
same-named member function of the appropriate team.
Mike Taylor [Fri, 7 Feb 2014 15:47:17 +0000 (15:47 +0000)]
Add logging from showDetails()
Mike Taylor [Fri, 7 Feb 2014 15:47:09 +0000 (15:47 +0000)]
Move some code around -- no effect.
Mike Taylor [Fri, 7 Feb 2014 15:42:50 +0000 (15:42 +0000)]
Vertical ws
Mike Taylor [Fri, 7 Feb 2014 15:41:52 +0000 (15:41 +0000)]
Remove now-redundant "for teamName" from logging invocations.
Mike Taylor [Fri, 7 Feb 2014 15:39:26 +0000 (15:39 +0000)]
Swap order of that.delimitTarget() and that.delimitQuery() to match
how we do things elsewhere.
Mike Taylor [Fri, 7 Feb 2014 15:38:52 +0000 (15:38 +0000)]
Fix misleading logging from delimitQuery()
Mike Taylor [Fri, 7 Feb 2014 15:38:36 +0000 (15:38 +0000)]
mkws.delimitTarget() and delimitQuery() now accept a team-name and
delegate to the appropriate team's member-functions of the
same name.
Mike Taylor [Fri, 7 Feb 2014 15:23:51 +0000 (15:23 +0000)]
Facet-related elements are identified by class rather than ID.
Mike Taylor [Fri, 7 Feb 2014 15:11:15 +0000 (15:11 +0000)]
Swap order of that.limitTarget() and limitQuery()
Mike Taylor [Fri, 7 Feb 2014 15:10:46 +0000 (15:10 +0000)]
Reverse order of showDetails() arguments to match limitTarget() and
limitQuery()
Mike Taylor [Fri, 7 Feb 2014 15:05:31 +0000 (15:05 +0000)]
mkws.limitQuery() now accepts a team-name and delegates to the
appropriate team's member-function of the same name.
Mike Taylor [Fri, 7 Feb 2014 15:02:06 +0000 (15:02 +0000)]
redraw_navi() made team-aware.
Facet divs made team-specific.
mkws.limitTarget() now accepts a team-name and delegates to the
appropriate team's member-function of the same name.
Mike Taylor [Fri, 7 Feb 2014 14:54:16 +0000 (14:54 +0000)]
debug() function's output begins with team name.
Wolfram Schneider [Fri, 7 Feb 2014 13:26:43 +0000 (13:26 +0000)]
config option disable_facet_authors_search, MKWS-114
it is better to have an config option than to assume that
it will never work with raw pazpar2
Wolfram Schneider [Fri, 7 Feb 2014 13:15:59 +0000 (13:15 +0000)]
ignore non-functional limit search for authors if running raw pp2, MKWS-114
Wolfram Schneider [Thu, 6 Feb 2014 17:27:48 +0000 (17:27 +0000)]
server alias a.mkws-dev.indexdata.com
Wolfram Schneider [Thu, 6 Feb 2014 17:06:11 +0000 (17:06 +0000)]
translate navi bar, MKWS-112
Wolfram Schneider [Thu, 6 Feb 2014 16:27:26 +0000 (16:27 +0000)]
update devel tools
Wolfram Schneider [Thu, 6 Feb 2014 16:25:02 +0000 (16:25 +0000)]
update to GPLv3
copied from https://www.gnu.org/copyleft/gpl.txt
Wolfram Schneider [Thu, 6 Feb 2014 16:22:33 +0000 (16:22 +0000)]
update modules list
Wolfram Schneider [Thu, 6 Feb 2014 16:15:58 +0000 (16:15 +0000)]
run phantomjs from root level dir
Wolfram Schneider [Thu, 6 Feb 2014 16:14:19 +0000 (16:14 +0000)]
nuke ./spec-sp - phantomjs does a much better job
Wolfram Schneider [Thu, 6 Feb 2014 16:08:14 +0000 (16:08 +0000)]
grammar
Wolfram Schneider [Thu, 6 Feb 2014 16:02:33 +0000 (16:02 +0000)]
display 10 hits by default, looks better on a small screen
Wolfram Schneider [Thu, 6 Feb 2014 16:00:45 +0000 (16:00 +0000)]
switch search term from "openssh" to "netbsd"
to get more than 10 hits, and display navigation bar
Wolfram Schneider [Thu, 6 Feb 2014 15:56:33 +0000 (16:56 +0100)]
Merge branch 'master' of ssh://git.indexdata.com:222/home/git/private/mkws
Conflicts:
test/Makefile
Wolfram Schneider [Thu, 6 Feb 2014 15:54:20 +0000 (16:54 +0100)]
bomb.pl - wrapper to stop a process after N seconds, MKWS-110
Wolfram Schneider [Thu, 6 Feb 2014 15:45:50 +0000 (16:45 +0100)]
documentation
argument checking
Mike Taylor [Thu, 6 Feb 2014 14:10:02 +0000 (14:10 +0000)]
Remove no-longer-needed logging.
Remove unnecessary blanking of new search box.
(That was causing a problem for second and subsequent teams.)
Initial hiding of termlists made term-aware.
Mike Taylor [Thu, 6 Feb 2014 12:26:14 +0000 (12:26 +0000)]
Use pp2's facet names ("xtargets", "subject", "author") instead of
unnecessary MKWS-specific variants ("sources", "subjects",
"authors").
The pp2 object is now initialised to fetch only the facets that we're
actually going to use, rather than blinding fetching all three
whether they're used or not.
No "onterm" callback function is provided when no facets at all are
required, so that PP2 is never asked for them. This is going
to be a significant optimisation when using multiple Fresco
widgets.
my_onterm() now raises an alert on the "can't happen" condition that
we are invoked when no facets were requested. This defensive
clause can be removed later.
Mike Taylor [Thu, 6 Feb 2014 12:21:10 +0000 (12:21 +0000)]
Updated list of facets.
Mike Taylor [Thu, 6 Feb 2014 12:20:26 +0000 (12:20 +0000)]
Updated default list of facets.
Mike Taylor [Thu, 6 Feb 2014 12:19:15 +0000 (12:19 +0000)]
Remove redundant configuration options.
Mike Taylor [Thu, 6 Feb 2014 11:36:37 +0000 (11:36 +0000)]
Simplify my_onterm logic.
Mike Taylor [Wed, 5 Feb 2014 17:42:07 +0000 (17:42 +0000)]
Move MOTDs to the bottom.
Fix team-name for second.
Mike Taylor [Wed, 5 Feb 2014 17:20:06 +0000 (17:20 +0000)]
Correct documentation for MOTD